Mabinogi World Wiki is brought to you by Charlie C., Coty C., our other patrons, and contributors like you!!
Want to make the wiki better? Contribute towards getting larger projects done on our Patreon!

Forum - Can't login to Mabinogi (or any of Nexon's websites for that matter)

Jump to: navigation, search
Overview > Mabinogi > Technical Support > Can't login to Mabinogi (or any of Nexon's websites for that matter)
[#1260]

So recently I've been having this issue where I can't get into Mabinogi. I'm also having an issue where I can access Nexon's websites but I can't login into them. Idk if those two issues are related, so I'll address them separately below.

1) On my dekstop specifically (which is what I use for gaming), I cannot login to any of Nexon's game websites. I can access the rest of the website just fine, but as soon as I try to login, the login page kinda just...fails to load. As in, it times out/fails to respond. I tried googling this issue, and some people have said that it's a Google Chrome problem. However, it persists even when I use Firefox. Strangely enough, I can access their websites AND login just fine on my old crappy laptop as well as my tablet, both of which run Google Chrome. So it seems to be an issue that their websites have with my desktop specifically. I've restarted my computer multiple times, and restarted my router a few times, but the issue seems to keep popping up, so I have no idea what to try next

2) I have Mabinogi downloaded on both Steam and the Nexon Launcher. On both platforms, I've been having an issue where after launching the game, the client opens up, but it lands me on Mabinogi's OLD login screen. (For those of you who haven't been playing for as long, all of Nexon's games used to have you login directly through the client, rather than having you login through a launcher or Steam so that you're already logged in when the client opens). And, of course, this old login screen just doesn't work. It won't take my email or PW even though I type both in correctly. I've fixed the issue on the Nexon Launcher by setting the Launcher to always Run as Administrator, but the problem still persists on Steam.

3) So I fixed the issue with the Nexon Launcher, and I now get the standard login screen for Mabinogi where it just has a Start Game button, and an Exit button. However, when I click the Start Game button, all I get is a popup that says "unknown error", with no other information. I've tried googling this issue and I basically haven't found any solutions. I have no idea what this error means and no idea how to fix it.

So TL;DR is I can't login to any of Nexon's websites on my desktop, even though they work fine on my laptop and tablet. I can't login to Mabinogi through Steam because the client lands on an old/outdated login screen rather than the screen with the Start Game Button. And I can't login to Mabinogi through the Nexon Launcher because the Start Game button gives me an "unknown error" popup.

I've tried repairing the installation for Mabinogi on both Steam and the NX Launcher, as well as just flat out uninstalling and reinstalling. Neither have worked, and I haven't found any real solutions on Google. If anyone has any experience with these issues, I'd appreciate any advice you can give me, cuz idk what to try next and this is getting just a little bit frustrating. =/

EDIT: The "Run As Administrator" fix has stopped working for the Nexon Launcher. So I'm now back to square one where both the Steam and Launcher versions end up with me on the old login screen.

Posted by Faux Caliburn on 23 May 2018 at 13:18.
Edited by Faux Caliburn on 23 May 2018 at 13:42.

You didn't say anything about disabling adblock, so I always suggest that first. Just try logging in incognito (with no plugins) and if that works you can figure it out more finely.

The only reason I know of for the launcher to show the old login screen is if you take too long to get to the landing page in the client from logging in. This is more of a thing for Nexon launcher since I think the countdown starts when you log in to the launcher? For Steam it's when you start the game of course, and it's hard to believe it would take that long. Though! The easy way for this to happen is by forgetting you ran Mabi and leaving the Run as Admin screen or the "your graphics card may not be good enough" screen up for way too long. There might be other ways to get to that screen but I have yet to hear of other relevant ones.

"Unknown error" is extremely unhelpful unfortunately and I haven't really heard of it in your case. People have had trouble running the game in full screen lately so if you are I'd suggest windowed mode but this isn't the error they were getting.

Posted by Kadalyn (administrator) on 25 May 2018 at 08:12.

You might also consider attempting an alternate DNS server (like 8.8.8.8) or even a VPN service in the event your ISP is not providing you a reasonable connection to nexon's game servers.

There also exists network "enhancers" that come preloaded onto some PCs (ASUS comes to mind). I don't know how old your PC is or if you made it yourself, but also consider turning any of those off, if you have them, to see if it helps. Nexon games are typically not on the priority list for these programs.

Posted by WhitePass on 27 May 2018 at 02:38.